afraid-scarlet
afraid-scarlet6mo ago

Does Refine support node 20.x?

Nice to meet you! I'm jjjjj from Japan. My local development environment is node 20.10.0. I just made refine project with the command yarn create refine-app, and I found @types/node": "^18.16.2" in package.json. So, should I use node 18.x ? or Can I change @types/node": "^18.16.2" to @types/node": "^20.10" ?
4 Replies
kapa.ai
kapa.ai6mo ago
Hi @jjjjj4450. I'm kapa.ai, your friendly support bot. I will try to answer your question by searching through the knowledge base. :wave: ---------------------- Hello jjjjj, nice to meet you too! Based on the information provided in the extracts, it seems that Refine does support Node 20.x. In one of the Github issues (https://github.com/refinedev/refine/issues/5279), a user reported an issue while using Node v20.9.0. However, the issue was not related to the Node version but to a specific package error. As for the @types/node version in your package.json, it's used for TypeScript definitions for Node.js and doesn't necessarily need to match your installed Node.js version. It's generally safe to have a lower version for @types/node than your actual Node.js version. However, if you encounter any issues or TypeScript errors related to Node.js APIs, you might consider updating @types/node to match your Node.js version. You can do this by running npm install @types/node@20.10.0 or yarn add @types/node@20.10.0. Please note that it's always a good idea to keep your Node.js and other dependencies up-to-date to benefit from the latest features and security updates. If you encounter any issues, feel free to ask for help in the community. ---------------------- Note: you can ask me a follow up question by @ mentioning me again :speech_balloon: ----------------------
kapa.ai
kapa.ai6mo ago
<@557959853134577664> kapa.ai is still learning and improving, please let us know how it did by reacting below
eastern-cyan
eastern-cyan6mo ago
Hello @jjjjj4450 welcome to Refine community! Although we didn't test with node@20, it shouldn't be a problem.
afraid-scarlet
afraid-scarlet6mo ago
Thank you so much!! I wil try node@20!!